Phrasing

Naming Things

Components, models and functions should be named descriptively to avoid ambiguity:

  • MousePosition instead of Position or Pos
  • decodeMousePosition instead of positionDecoder or mousePositionDec

Variable names

The following names should be used across the code base to avoid ambiguity:

  • Position in 2d space:
    • top instead of pageY or x
    • left instead of pageX or y
    • height instead of innerHeight
    • width instead of innerWidth

results matching ""

    No results matching ""